Jump to content


Willkommen im Coresystems Community Forum

Dieses Forum wird nicht mehr weiter betrieben.
Sollten Sie eine Lösung für eine spezifische Aufgabenstellung suchen wenden Sie sich bitte an unseren Support: helpdesk.coresystems.ch.
Für allgemeine Produktinformationen kontaktieren Sie unser Sales-Team: sales@coresystems.ch

Welcome at the coresystems community forum

This forum is no longer being maintained.
If you need a specific solution please contact our support: helpdesk.coresystems.ch.
For general product information do not hesitate to contact our sales team: sales@coresystems.ch

Photo

PVR code: wrong string read by scanner


  • Please log in to reply
4 replies to this topic

#1 Emanuele Croci

Emanuele Croci

    Advanced Member

  • Members
  • PipPipPip
  • 358 posts

Posted 7 November 2013 - 10:51

Dear all,

 

tool: SAP 8.82 SwissPayment functionality to read the PVR code via scanner to load Swiss invoices…

 

For one our customer, when she read the code on the PVR via scanner it reads

swa-pi-start0100000665305>000000000107534216024349242+ 010721836> s

 

instead of: “0100000665305>000000000107534216024349242+ 010721836”

 

Do you know how and if I can configure this tool to read well the PVR code?

 

See attached image.

 

Best regards

 

   Emanuele

 

Attached Thumbnails

  • Wrong_PVR_String.jpg


#2 Beat Meier

Beat Meier

    Member

  • Moderators
  • 24 posts

Posted 7 November 2013 - 11:18

Hi Emanuele,

 

this looks like the Scanner is not configured properly. The scanner should read/send the following string to the application: swa-pi-start0100000665305>000000000107534216024349242+ 010721836>swa-pi-end

 

Could you make sure, that the ending of the string is correct too. You might want to check the scanner inside a simple notepad and read the PVR code there and you'll see what the scanner delivers to notepad.

 

Regards,

Beat



#3 Emanuele Croci

Emanuele Croci

    Advanced Member

  • Members
  • PipPipPip
  • 358 posts

Posted 7 November 2013 - 11:28

Dear Beat,

probably you are right...

 

The customer uses SAP B1 8.81 (in production environment) using SAP B1 client on her PC, and scanner works fine.

 

The customer connects to SAP 8.82 TEST Server via terminal server and here she runs SAP B1 client and the scanned string is wrong.

Should I also install the scanner driver on the SAP B1 8.82 server and configure it?

 

Sorry, but I'm newby on SwissPayment and it's a new customer for us and we don't know all its environment.

 

Best regards

 

    Emanuele



#4 Beat Meier

Beat Meier

    Member

  • Moderators
  • 24 posts

Posted 7 November 2013 - 11:44

Hi Emanuele,

 

we know that sometimes it can get strange behavior when using Terminal Server. We experienced sometimes that it makes a difference, if you connect the Scanner before or after you connected to the Terminal Server. This has only indirectly something to do with SwissPayment. It is important that you can scan the PVR inside Terminal Server in a normal notepad, if that works, it will work in SAP B1 too.

 

Sorry I can't give you a final answer here, you have to find out why the scanner reads differently while using Terminal Server.

 

Regards

Beat



#5 Emanuele Croci

Emanuele Croci

    Advanced Member

  • Members
  • PipPipPip
  • 358 posts

Posted 7 November 2013 - 12:00

Dear Beat,

I tested the scanner opening Notepad on the PC and on the terminal server...

 

on the PC it reads:

0100000665305>000000000107534216024349242+ 010721836>

 

on terminal server it reads this string:

0100000665305<0000000001075342160243492421 010721836<

 

Some characters are read wrong on the terminal server.

 

Fortunately, the terminal server connection is needed only in this test phase. After migration, users will continue to use SAP from their own PCs.

 

Best regards

 

    Emanuele






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users